Beware of phishing attacks, Ledger will never ask for the 24 words of your recovery phrase. Never share them. Learn more

MetaMask x Ledger Connection Issue On Firefox

Firefox version 114.0 and above no longer support connecting Ledger devices to MetaMask, resulting in an error.

This change is due to Firefox dropping support for the legacy U2F JavaScript API.

Workaround

  • To continue using MetaMask with your Ledger, we recommend switching to Chrome or Brave until a fix is deployed by the Firefox team.
  • Alternatively, you have the option to install an older version of Firefox; however, we do not recommend this for security reasons.

Was this article helpful?